E-logger | Manualer | Forum
Loggerforum - supportforum
2020-09-21 00:52 *
Välkommen Gäst. Var snäll och logga in eller registrera dig som ny medlem.

Logga in med användarnamn, lösenord och önskad sessionslängd
 
   Forum   Hjälp Sök Logga in Registrera  
Sidor: [1]
  Skriv ut  
Författare Ämne: Laddbox med förinstallerad Modbus 1-fas elmätare  (läst 656 gånger)
Steve Granqvist
Medlem

Antal inlägg: 7


Visa profil
« skrivet: 2020-07-30 13:54 »

Hej alla!

Jag har införskaffat en Logger 3030 PRO och har precis påbörjat uppkoppling mot fyra stycken elmätare med Modbus-kommunikation.
Min korta fråga är som följer:

Jag vill (såklart) logga min laddbox och den levererades med en elmätare med Modbus förinstallerad.
Nu finns ju naturligtvis inte den som förval när man ska lägga upp sin mätare/givare.
Är jag tvingad att investera i en 1-fasmätare från Energibutiken som finns upplagd redan eller finns det en work around runt det här?

Elmätaren är en Carlo Gavazzi och modellen är en EM111. Laddboxen är en GARO så det kanske är fler användare som har kikat på det här problemet!?

 Tack på förhand!
Loggat
Rickard
Global Moderator
*****
Antal inlägg: 1514



Visa profil Hemsida
« Svara #1 skrivet: 2020-07-31 08:50 »

Vi får kontakta Garo så de börjar installera bättre mätare.  Med glimten i ögat (blinkande)

Lite beroende på Andreas arbetsbelastning så brukar han kunna anpassa loggern till mätare som vi tror kommer att efterfrågas av fler, detta är ett sånt exempel kan jag tycka, men avvakta tills han läser detta så kommer det nog ett svar.
Normalt vill han i så fall ha en mätare skickad till sig så han kan testa direkt.
Är det något du kan tänka dig att göra?
Loggat

Steve Granqvist
Medlem

Antal inlägg: 7


Visa profil
« Svara #2 skrivet: 2020-07-31 11:21 »

Jag kan tänka mig att ersätta min elmätare med en provisorisk "dum" mätare och låna ut min. Hur lång utlåningstid brukar man prata om i så fall?  Leende (smiley)
Loggat
Andreas
Administrator
*****
Antal inlägg: 3147


Visa profil
« Svara #3 skrivet: 2020-08-03 09:46 »

Hej!

Fick tidigare en fråga om Carlo Gavazzi EM340 och EM111 av Magnus Andersson i den här tråden http://e-logger.se/forum/index.php?topic=1899.0. Vi hördes sedan på privat meddelande och jag gjorde en första testmjukvara som han skulle provköra. Men det kom saker emellan så Magnus har inte kunnat testa, och sen lät det som han ändå skulle skicka mätare, så vi får väl se hur det blir.

Om du vill kan du testa enligt följande:
1) Gå till inställningar->konto och uppdatera loggerns mjukvara till 200612.
2) Gör loggern strömlös. Koppla in EM111 till loggerns modbus-plint, var noga med rätt polaritet. Anslut loggern till nätadaptern igen.
3) Kolla i Carlo Gavazzi-manualen hur du ändrar adress på EM111 och ställ in den på första lediga adress högre än 10.
4) Gå sen till inställningar->givare->panelen "Seriella enheter Modbus/M-bus" och välj "Sök enheter" och "Modbus Carlo Gavazzi EM111" och välj rätt baudrate och vald adress ovan. Prova söka åtminstone 5 ggr innan du ger upp.
5) Om elmätaren hittas så klicka "hantera" i panelen "Seriella enheter Modbus/M-bus" och lägg till register för spänning och räkneverk. Vänta tills värden kommer in och kolla om de som visas i loggerns display verkar stämma.

Det är alltid vanskligt att få sådant här rätt utan att kunna testa, det kan krävas ganska många provkörningar innan det blir som det skall. Så det är därför jag helst lånar en mätare. Det brukar ta ett par dar.
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
Steve Granqvist
Medlem

Antal inlägg: 7


Visa profil
« Svara #4 skrivet: 2020-08-03 14:40 »

Strålande! Jag ska testa enligt dina instruktioner, men det kommer att ske om c:a en vecka då jag är bortrest just nu.

Jag är fortfarande inte främmande för att skicka mätaren om vi märker att det behövs.

 Tack så länge och på återkommande...   Leende (smiley)
Loggat
Steve Granqvist
Medlem

Antal inlägg: 7


Visa profil
« Svara #5 skrivet: 2020-08-12 20:01 »


 God kväll!

Jag har uppdaterat min logger utan problem och har nu tre stycken tillagda Eastron SDM630 på adresser 11, 12 och 13.
Samtliga med Baud rate 9600 och Stop Bit 1.

Jag har lagt min Carlo Gavazzi EM111 på adress 14 med Baud Rate 9600 och Parity "no" och Stop Bit 1 men loggern tycks inte hitta den trots otaliga "sök".
EM111 ligger dessutom först i Modbus-slingan så det SKA inte vara något inkopplingsfel av slingan till mätaren...

 Tips?

   Leende (smiley)
Loggat
Andreas
Administrator
*****
Antal inlägg: 3147


Visa profil
« Svara #6 skrivet: 2020-08-13 22:14 »

God kväll! Tack för testkörningen. Jag skall kolla om jag ser något som verkar underligt i programkoden, återkommer på ett par dar!
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
Andreas
Administrator
*****
Antal inlägg: 3147


Visa profil
« Svara #7 skrivet: 2020-08-19 14:07 »

Hej!

Nu har jag tittat och dessvärre ser jag inget uppenbart fel. Hade jag haft mätaren på kontoret hade jag i det här läget kopplat upp oscilloskopet för att se vad som händer. Troligast är att det är något i anropet som inte stämmmer. Vad vi kan göra är att se om det går få ut mer felsökningsinfo, har lagt till stöd för det i mjukvaran. Gå till inställningar->konto och uppdatera loggerns mjukvara till 200819. Gör sen ett par sökningar igen.

Jag antar att du redan kollat detta ett par gånger, men är du fullständigt säker på att polariteten på modbus-anslutningen till mätaren är rätt?
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
Steve Granqvist
Medlem

Antal inlägg: 7


Visa profil
« Svara #8 skrivet: 2020-08-20 17:07 »


 Hej!

Jag har uppdaterat min logger enligt instruktion (smärtfritt även denna gång) och så har jag gjort ett 10-tal sök utan lyckat resultat tyvärr... Jag har tidigare varit ut till mätaren och kollat polaritet och lossat och anslutit om Modbus-kabeln på mätaren (så att det inte var klämd isolering eller dylikt).
Nyss var jag ute igen för att kolla polariteten och det ser sjyst ut enligt manualen från Carlo Gavazzi.
Loggat
Steve Granqvist
Medlem

Antal inlägg: 7


Visa profil
« Svara #9 skrivet: 2020-08-20 17:40 »


 Succé !!!

Nu har jag lyckats lägga till min EM111 till min Logger 3030 PRO!

Lösning: Polaritetsvänd anslutningarna!
                (men det förslaget har ju redan nämnts i tidigare svar i den här tråden...  Rullande ögon (ironi) )
             Jo absolut. Men följer man Carlo Gavazzis instruktioner "em11_im.pdf" eller "EM111DINAV81XM1X_eng_tds.pdf" så står det att A- ligger på anslutning 8 och B+ ligger på anslutning 6, men det ska vara tvärtom.

Jag ville bara vara tydlig med att man testar att byta polaritet (som rekommenderas) vid anslutning av ny mätare/utrustning vid problem. det är inte säkert att tillverkarens instruktioner alltid är korrekta...

Nu kommer en annan liten fundering.
Är tanken att det ska läggas till lite fler avfrågningsbara parametrar till mätaren då jag gärna vill ha Ampere och Effekt momentant?

  Tack så länge!
Loggat
Andreas
Administrator
*****
Antal inlägg: 3147


Visa profil
« Svara #10 skrivet: 2020-08-21 10:13 »

Hej! Toppen!

Har du installerat termineringsmotstånd i din Modbus-slinga? Har man inte många mätare, långa kablar eller störig miljö behövs det inte, men det kan vara så att Carlo Gavazzi förväntar sig terminering för att kunna automat-detektera polaritet. Så en gissning är att det är anledningen till att fel blir rätt.

Har nu lagt till ström och effekt. Carlo Gavazzi-mätarna (EM300, ET300, EM100 och ET100-serierna) är lite udda då de har olika skalning på olika parametrar, så därför behöver du uppdatera loggermjukvaran ytterligare en gång innan du kan prova. Testa gärna spänning också så vi hör att skalningen blir rätt för den med.
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
Steve Granqvist
Medlem

Antal inlägg: 7


Visa profil
« Svara #11 skrivet: 2020-08-23 18:34 »


 Hej!

Nu är vi på banan...  Leende (smiley)

Nej, jag har inget termineringsmotstånd, så det kan naturligtvis ligga något i det du skriver. Jag har, från loggern räknat, Gavazzin först och sedan tre stycken trefasmätare från Eastron av modellen SDM630. Inget "stjärn-nät" utan alla i en slinga med skärmad nätverkskabel...

Jag har kopplat ström, spänning, effekt och mätarställning för att se att upplösningarna är okej.

Effekten visas med två decimaler i EM111 och visas även så i e-logger. Stämmer mot varandra.
Spänning visas med en decimal i EM111 och visas med två decimaler i e-logger. Stämmer mot varandra, men den sista decimalen i e-logger är överflödig  Leende (smiley)
Ström visas med två decimaler i EM111 och visas med två decimaler i e-logger. Stämmer mot varandra, men upplösningen är bara en decimal i e-logger.
Mätarställning visas med två decimaler i EM111 och visas med två decimaler i e-logger. Stämmer mot varandra, men upplösningen är bara en decimal i e-logger.

 Summerat så är jag väldigt nöjd med hur det har löst sig!

  Tack!
Loggat
Andreas
Administrator
*****
Antal inlägg: 3147


Visa profil
« Svara #12 skrivet: 2020-08-24 09:46 »

Toppen, tack så mycket för hjälpen med provkörningen!  Leende (smiley)
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
Sidor: [1]
  Skriv ut  
 
Gå till:  

Drivs med MySQL Drivs med PHP Powered by SMF 1.1.21 | SMF © 2011, Simple Machines Giltig XHTML 1.0! Giltig CSS!