E-logger | Manualer | Forum
Loggerforum - supportforum
2018-12-17 11:52 *
Välkommen Gäst. Var snäll och logga in eller registrera dig som ny medlem.

Logga in med användarnamn, lösenord och önskad sessionslängd
 
   Forum   Hjälp Sök Logga in Registrera  
Sidor: [1]
  Skriv ut  
Författare Ämne: M2M: inga anrop görs av loggern?  (läst 210 gånger)
Per Hallström
Medlem

Antal inlägg: 3


Visa profil
« skrivet: 2018-11-01 08:46 »

Hej! Har en Logger 3030 som just nu är inkopplad till bara en enda givare. Försöker få loggern att POSTa data till en godtycklig server, men verkar inte kunna få det att fungera. Detta har jag gjort/kollat:

— Sett till att servern lyssnar på ett publikt IP, på port 80, och trafik tillåts.
— Jag kan POSTa med curl från samma nätverk som Logger körs på.
— Jag har ställt in M2M med intervall 1 minut, och verifierat att serveradressen är korrekt.
— Under Settings > M2M på loggern ser jag följande:
    -
    1 minute
    <endast hostname för server>

Eftersom detta är en publik server har jag redan fått en del konstiga requests från det vilda Internet, så den är helt klart öppen för trafik. Även om loggern fick något svar den inte gillade (den bör få en 200 OK tillbaka, dock) så ser jag inte ens att den skickar någon request. Tips emottages tacksamt!
Loggat
Andreas
Administrator
*****
Antal inlägg: 2886


Visa profil
« Svara #1 skrivet: 2018-11-01 10:39 »

Hej!

Hur menar du med "<endast hostname för server>", är det något som fattas i serveradressen menar du?

Har du kanske en väldigt lång serveradress så att den inte får plats hel och hållen?
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
Per Hallström
Medlem

Antal inlägg: 3


Visa profil
« Svara #2 skrivet: 2018-11-01 13:23 »

Hej Andreas, adressen inklusive sökväg är 68 tecken.

I fältet under M2M-inställningar har jag (något anonymiserat)
        ec2-111-22-33-44.eu-central-1.compute.amazonaws.com/xxxxxxxxxxxx

På displayen ser jag
        -
        1 minute
        ec2-111-22-33-44.eu-central-1.compute.amazonaws.com
Loggat
Andreas
Administrator
*****
Antal inlägg: 2886


Visa profil
« Svara #3 skrivet: 2018-11-01 16:55 »

Hej!

Problemet verkar vara att servernamns-delen är mer än 50 tecken, det behövs en mjukvarufix för det i Logger 3030. Du kanske kan använda nån tinyurltjänst så länge?
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
Per Hallström
Medlem

Antal inlägg: 3


Visa profil
« Svara #4 skrivet: 2018-11-01 19:43 »

Aha, okej. Då löser vi det tillfälligt genom att ange IP-adressen istället. Den är ändå samma så länge den där EC2-burken är uppe. Ser fram emot uppdatering, men just nu finns det en lösning då i alla fall. Har bekräftat att det fungerar med IP-adressen. Tack för snabb lusläsning av koden!
Loggat
Andreas
Administrator
*****
Antal inlägg: 2886


Visa profil
« Svara #5 skrivet: 2018-11-02 14:04 »

Tack för att du bekräftade att det fungerade med IP-adressen! Lägger med en åtgärd i nästa uppdatering.
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
Sidor: [1]
  Skriv ut  
 
Gå till:  

Drivs med MySQL Drivs med PHP Powered by SMF 1.1.21 | SMF © 2011, Simple Machines Giltig XHTML 1.0! Giltig CSS!