E-logger | Manualer | Forum
Loggerforum - supportforum
2018-10-22 01:30 *
Välkommen Gäst. Var snäll och logga in eller registrera dig som ny medlem.

Logga in med användarnamn, lösenord och önskad sessionslängd
 
   Forum   Hjälp Sök Logga in Registrera  
Sidor: [1]
  Skriv ut  
Författare Ämne: Spikar i mätvärden via Modbus [nivåmätare ultraljud]  (läst 1403 gånger)
vattenverket
Medlem

Antal inlägg: 24


Visa profil
« skrivet: 2017-05-29 17:11 »

Uppgraderade logger 3030 till senaste versionen 170523 i helgen och efter det har det blivit fler spikar som förstör mätvärden. Främst gäller det Nivågivare "ekolod" 0-5 meter via Modbus. Försökte infoga en bild men lyckades inte.
//Sven-Ulrik
Loggat
Andreas
Administrator
*****
Antal inlägg: 2849


Visa profil
« Svara #1 skrivet: 2017-05-29 17:37 »

Främst nivågivare, betyder det att det finns spikar på andra kanaler också, och i så fall på alla kanaler eller bara vissa? Om inte alla kanaler, finns nån gemensam nämnare för de kanaler där det förekommer spikar.

Vad använder ni för typ av internetuppkoppling? Det kan ibland uppstå problem med långsamma förbindelser. Är det ett mobilnät med dålig täckning kan bättre inriktning av antennen eller bättre antenn hjälpa.
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
vattenverket
Medlem

Antal inlägg: 24


Visa profil
« Svara #2 skrivet: 2017-05-29 21:48 »

Uppkopplingen är en 4G uppkoppling. Utomhus antenn är monterad och signalen är 93 % av max. Den har gått ned 3 gånger under den 14 dagar, tiden allt varit i drift. Jag får ett mail vid sådana tillfällen. Jag har inte sett något samband mellan spikarna och omstart av router. Det finns 3 vattenmätare på pulsingångar där har jag bara noterat mariginella avvikelser. Det finns även en kombinerad temperatur och fuktmätare. Några mindre skipar båda avsende fukt och temperatur. Nivåmataren mäter vattenytan i råvattenbassängen uppifrån och till vattenytan. Stora spikar send i söndags kväll och idag strax efter 12.00 idag. Den i söndags morse redigrade jag dessvärre bort. Nivågivaren inställd på 2400 baud, kanal 12. Logger på mätvärde var 30:e sekund. Just nu kom det en spik till. Det verkar ske när råvatten pumparna stängs av. Det märkliga är att det inte skedde före uppgraderingen av loggern. Försökt svara flera gånger. Hoppas det blir 1 post.
Loggat
Andreas
Administrator
*****
Antal inlägg: 2849


Visa profil
« Svara #3 skrivet: 2017-05-30 08:48 »

Är en enda Modbus-enhet ansluten till loggern? I så fall är det inte konstigt om det blir mer störningar efter uppdateringen, innan uppdateringen fanns, då en enda enhet var ansluten, ett fel som gjorde att loggningen "frös" värdet under 115-minutersperioder.

Sitter nivåmätaren alldeles rakt riktad? Det jag noterade när jag provkörde en av dem var att om de sitter snett så blir det ibland felavläsningar.

Intressant iaktagelse med råvattenpumparna, kan det kanske vara så att det blir en krusning på vattenytan när de stängs av som gör att det blir störningar?
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
vattenverket
Medlem

Antal inlägg: 24


Visa profil
« Svara #4 skrivet: 2017-05-30 19:02 »

Har följt värdena i 14 dagar och det finns inga avbrott i mätningarna. Om jag tittar noga så har jag idag en mindre spik i nivåmätningen. Det förekommer även en liten spik i kurvan för Råvatten B vid samma tidpunkt. Ekolodet sitter absolut vinkelrätt mot vattenytan. Det mäter så noga så att man kan se vågorna i bassängen då Råvatten B pumpar in vatten Råvatten B pumpar in 43 liter per minut och vattnet faller så att det hela tiden blir vågor. Ytan i bassängen är 22,5 kvm. Jag misstänker eventuellt strömförsörjningen. Om man ska göra något åt kvalitén på strömmen så är ju alternativen bättre el-adaptrar med bättre filtrering eller en UPS med sinuskurva. // Sven-Ulrik     
Loggat
Andreas
Administrator
*****
Antal inlägg: 2849


Visa profil
« Svara #5 skrivet: 2017-05-31 08:44 »

Felet jag talar om gjorde inte att det blir avbrott i mätningarna utan att mätvärdet fastnade på samma värde under en period. Det syns om man zoomar in max i kurvan, att den periodvis är alldeles rak utan brus.

Har du gjort en graf med både råvattenpump och nivåmätare i samma graf så du säkert ser sambandet?

Ja, det är inte otroligt att nivåmätaren är känslig för risig nätspänning. Enklaste sättet att utesluta det borde vara att tillfälligt prova köra den på batteri. Går det kanske enkelt att slå på och av pumpen några gånger för att se sambandet?

Om du zoomar in spikarna max (ange tidsrymd 15 minuter i grafen), hur långa är spikarna då? Eventuellt kanske vi kan filtrera bort dem i mjukvara.
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
vattenverket
Medlem

Antal inlägg: 24


Visa profil
« Svara #6 skrivet: 2018-02-12 09:39 »

Spikarna har numera försvunnet (av sig själv). Jag vet inte varför men är nöjd med det. Miljön där utrustningen sitter är inte den bästa med 3-faspumpar som startar och delvis sänker elen.
Loggat
Andreas
Administrator
*****
Antal inlägg: 2849


Visa profil
« Svara #7 skrivet: 2018-02-12 10:01 »

Jag förstår, tack för återkopplingen!
Loggat

Läs igenom manualen och sök efter svar i forumet innan du frågar. Ställ dina frågor i forumet, vi ger ej personlig support. Obs! Regel 2: dålig stämning = avstängning, i detta forum är vi hjälpsamma och trevliga!
Sidor: [1]
  Skriv ut  
 
Gå till:  

Drivs med MySQL Drivs med PHP Powered by SMF 1.1.21 | SMF © 2011, Simple Machines Giltig XHTML 1.0! Giltig CSS!